iDeneb 10.5.8 problem z kextem

Ogólne rozmowy związane z działaniem oraz obsługą systemu Leopard (10.5) na platformie OSx86.
Regulamin działu
Na podstawowe pytania można znaleźć odpowiedź w dziale "Jak zacząć?"

W tym dziale nie piszemy o problemach:
- z instalacją
- ze znalezieniem sterowników (kextów)
- z programami

Nie podpinamy się pod stare/inne wątki jeśli nasz jest na inny temat niż pierwszy post.
Zachęcamy do zakładania nowych tematów.

Re: iDeneb 10.5.8 problem z kextem

Postprzez gec135 » 2 cze 2010, o 15:15

VoodooHDA działa!
O grafikę pytałem dlatego, że zamierzam instalować iWorks, a do tego jest potrzebne QE/CI. Próbowałem, ale bez kextów od grafiki chyba się nie obędzie. Może znacie jakiś sposób na włączenie QE/CI bez kextów od grafy?
gec135
 
Posty: 8
Dołączył(a): 9 maja 2010, o 10:54

Re: iDeneb 10.5.8 problem z kextem

Postprzez grzesiek811 » 2 cze 2010, o 17:22

Co do grafiki to pewnie że znamy takie sposoby. Nawet już pisałem Ci o tym. Są 2 sposoby jej uruchomienia bez kextów. Kext to dopiero 3 sposób. Pierwszy to graphics enabler, drugi efi string, trzeci to kext.

GTS250 to to samo co mój 9800GTX+, nawet EFI string jest identyczny. Działa na pewno. Sprawdzałem wszystkie 3 sposoby wszystkie działają, działa QE/CI.

1. Sposób - Graphic enabler - do tego potrzebny jest chyba chameleon 2 RC4, na wcześniejszych może nie działać.
w pliku com.apple.Boot.plist wpisujesz:
Kod: Zaznacz cały
<key>GraphicsEnabler</key>
<string>Yes</string>


Jeżeli masz bios AWARD (np. na płytach Gigabyte), to wpis wygląda tak:
Kod: Zaznacz cały
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>PciRoot</key>
<string>1</string>


Aby sprawdzić, czy dopisek PciRoot jest potrzebny należy sprawdzić za pomocą terminala PciRoot naszej płyty głównej:
Kod: Zaznacz cały
ioreg -l | grep -15 &#8220;AppleACPIPCI\ &#8221; | grep UID


Jeśli będzie to "0" to nic nie musimy robić, bo jest to wartość domyślna.
Jeśli będzie to "1" to trzeba do pliku apple.com.Boot.plist dodać wpis PciRoot

Ty masz gigabyte więc spróbuj ten drugi dłuższy wpis. Mam gigabyte GA-EP45-DS3P i u mnie działa właśnie ten drugi wpis.

2. Sposób - EFI string

Do pliku com.apple.Boot.plist wpisujemy:

<key>device-properties</key>
<string>6a020000 [...] 6495d</string>

W klamrach string wpisujemy wartość dla naszej karty. Efi string można wygenerować np. za pomocą efi studio lub osx86 tools.

3. Kext - najlepiej NVEnabler.kext
Instalujemy do E/E lub S/L/E najłatwiej za pomocą kext utility.

Jak zrobisz dobrze, to każda z metod zadziała na 100%. Działaj.
System: OS X 10.6.3 Snow Leopard Retail
Płyta główna: Gigabyte GA-EP45-DS3P
Procesor: Core2Quad Q9300
Karta graficzna: GeForce 9800GTX+
Pamięć: 3GB DDR2 667MHz
HDD: SATA: WD 160GB, Seagate 500GB, WD 1TB
Dźwięk: Realtek ALC889A
grzesiek811
 
Posty: 41
Dołączył(a): 22 maja 2009, o 23:43

Re: iDeneb 10.5.8 problem z kextem

Postprzez gec135 » 24 cze 2010, o 13:43

Przepraszam, że tak długo zostawiłem temat bez opieki :). zadziałało dopiero efi-string. Wygląda pięknie, jak się patrzy. Dzięki za pomoc. :)
gec135
 
Posty: 8
Dołączył(a): 9 maja 2010, o 10:54

Poprzednia strona

Powrót do OSx86 Leopard (10.5) ogólnie

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość

cron