Instalacja STAC9227 (SigmaTel) Wgranie kextu.

Problemy i sterowniki (kexty) do kart muzycznych.

Instalacja STAC9227 (SigmaTel) Wgranie kextu.

Postprzez pego » 9 lut 2009, o 23:56

Znalazlem rozwiązanie do tego aby moja karta dźwiękowa zaczęła działać:
http://www.insanelymac.com/forum/index. ... pic=134879

Jednak po ścignięciu próbowałem zainstalować ten kext KextHelperem, ale niestety nie mogłem kliknąć w w "easy install" (niewiedziec czemu)

Check if you are using another AUDIO injector like EFI strings or ALCinject and remove it otherwise it will not works.
If you are using HDAEnabler.kext REMOVE IT and use the new one (different LayoutID).
AppleHDA.kext version is 1.2.4a21 from 10.4.9 and MUST stay in S/L/E otherwise it won't works.


Nie mniej (pewnie to było bezsenowne ale) skopiowałem poprostu ten kext do folderu extension. Oczywiście nic to nie dalo oprocz bledu ktory wyskakiwał na poczatku że "kext został źle wgrany" Ale zastanawiam się (czytając to co przytoczyłęm z zagranicznego forum) czy nie powinieniem z folderu extensions wykasować wszytskich innych kextów audio (bo troche ich tam jest) aby działał ten który chce zainstalować. Ale nie rozumiem o co chodzi z tym:
...and MUST stay in S/L/E otherwise it won't works
OS: iAtkos 10.5.5
MB:Intel DG965SS (965)
CPU:Intel Pentium D 2.66GHz
VGA:NVIDIA GeForce8600GT 256MB (DDR2)
RAM:GoodRam 3x1GB (667mHz)
LAN: Intel 82566DC Gigabit
Audio:SigmaTel HD Audio STAC9227
HDD:WD 250GB SATA
DVD:LiteOn SATA
Avatar użytkownika
pego
 
Posty: 135
Dołączył(a): 31 gru 2008, o 00:53

Re: Instalacja STAC9227 (SigmaTel) Wgranie kextu.

Postprzez woytas » 10 lut 2009, o 00:03

No musisz usunąć w cytacie, który wkleiłeś wyraźnie jest napisane żeby usnąć pozostałe stery audio takie jak: ALCinject, HDAEnabler.kext,
Macbook White 2,1 : Core2Duo 2Ghz, 2GB DDR RAM GMA950
Avatar użytkownika
woytas
 
Posty: 249
Dołączył(a): 8 sty 2008, o 10:47

Re: Instalacja STAC9227 (SigmaTel) Wgranie kextu.

Postprzez pego » 10 lut 2009, o 00:08

Nie przypominam sobie żeby w folderze Extensions takie byly, ale poszukam. A co z tymi innymi bo jest tam wiele sterowników wskazujących że mają wiele wspólnego z audio. Rozumiem że potem mam wgrać to osx86 tools, tak?
OS: iAtkos 10.5.5
MB:Intel DG965SS (965)
CPU:Intel Pentium D 2.66GHz
VGA:NVIDIA GeForce8600GT 256MB (DDR2)
RAM:GoodRam 3x1GB (667mHz)
LAN: Intel 82566DC Gigabit
Audio:SigmaTel HD Audio STAC9227
HDD:WD 250GB SATA
DVD:LiteOn SATA
Avatar użytkownika
pego
 
Posty: 135
Dołączył(a): 31 gru 2008, o 00:53

Re: Instalacja STAC9227 (SigmaTel) Wgranie kextu.

Postprzez pego » 10 lut 2009, o 03:12

No i troche sie posypalo. Dzwieku jak nie bylo tak nie ma. Sterownik jest widzialny w bisoie ale nic pozatym. Nie wiem czy cos przeoczyłem?
http://www.insanelymac.com/forum/index.php?showtopic=134879&st=20&p=977145&#entry977145


Zainstalowalem STAC9227.v2.zip (jesli mozecie zobaczyc na plik readme) Wydaje mi sie czy abym nie musial zrobic czegos jeszcze.. Dzwiek nie dziala, kiedy chce wlaczyc cos w itunes to nawet nie rusza play kiedy wciskam. Zniknal rowniez pasek glosnosci w finder'ze. Co mozna zrobic w tym wypadku?
OS: iAtkos 10.5.5
MB:Intel DG965SS (965)
CPU:Intel Pentium D 2.66GHz
VGA:NVIDIA GeForce8600GT 256MB (DDR2)
RAM:GoodRam 3x1GB (667mHz)
LAN: Intel 82566DC Gigabit
Audio:SigmaTel HD Audio STAC9227
HDD:WD 250GB SATA
DVD:LiteOn SATA
Avatar użytkownika
pego
 
Posty: 135
Dołączył(a): 31 gru 2008, o 00:53

Re: Instalacja STAC9227 (SigmaTel) Wgranie kextu.

Postprzez rzooff » 10 lut 2009, o 10:34

Gdzie niby jest widzialny ten sterownik?
W jaki sposób usuwałeś stare kexty i dodawałeś nowe?
Retail 10.6.3(64bit) + Chameleon 2 | ASUS P5B-V | C2D E4600 2,4 Ghz | 4GB DDR2 800Mhz | GeForce 8400GS
Retail 10.6.3(32bit) + Chameleon 2 | Toshiba Satellie L40-17R
rzooff
 
Posty: 1114
Dołączył(a): 19 gru 2008, o 13:21
Lokalizacja: warszawa

Re: Instalacja STAC9227 (SigmaTel) Wgranie kextu.

Postprzez pego » 10 lut 2009, o 10:59

rzooff napisał(a):Gdzie niby jest widzialny ten sterownik?
W jaki sposób usuwałeś stare kexty i dodawałeś nowe?


Wczesniej w preferencjach systemowych przy sterowniku audio nie bylo nic, a teraz jest tam nazwa sterownika. Chodz mimo to nie dziala nadal dzwiek. Kexty audio wyrzucilem z katalogu systemowego Extensions i poprzez 0sx86 tools zainstalowalem kext ktory jest w linku ktory podalem. Zastanawiam sie dlaczego nie mam paska glosnosci w finderze.
OS: iAtkos 10.5.5
MB:Intel DG965SS (965)
CPU:Intel Pentium D 2.66GHz
VGA:NVIDIA GeForce8600GT 256MB (DDR2)
RAM:GoodRam 3x1GB (667mHz)
LAN: Intel 82566DC Gigabit
Audio:SigmaTel HD Audio STAC9227
HDD:WD 250GB SATA
DVD:LiteOn SATA
Avatar użytkownika
pego
 
Posty: 135
Dołączył(a): 31 gru 2008, o 00:53

Re: Instalacja STAC9227 (SigmaTel) Wgranie kextu.

Postprzez rzooff » 10 lut 2009, o 11:53

Usuwanie kextów też należy zrobić odpowiednio -> kext helper i remove kext. Dopiero wtedy instaluj nowe.
Retail 10.6.3(64bit) + Chameleon 2 | ASUS P5B-V | C2D E4600 2,4 Ghz | 4GB DDR2 800Mhz | GeForce 8400GS
Retail 10.6.3(32bit) + Chameleon 2 | Toshiba Satellie L40-17R
rzooff
 
Posty: 1114
Dołączył(a): 19 gru 2008, o 13:21
Lokalizacja: warszawa

Re: Instalacja STAC9227 (SigmaTel) Wgranie kextu.

Postprzez pego » 10 lut 2009, o 12:13

No wasnie tyle ze kext helper nei bardzi mi dzialal. A deinstlacja kextow odbywa sie na zasadzie przecigniecia kextu do tego programu i usuniecia`?
OS: iAtkos 10.5.5
MB:Intel DG965SS (965)
CPU:Intel Pentium D 2.66GHz
VGA:NVIDIA GeForce8600GT 256MB (DDR2)
RAM:GoodRam 3x1GB (667mHz)
LAN: Intel 82566DC Gigabit
Audio:SigmaTel HD Audio STAC9227
HDD:WD 250GB SATA
DVD:LiteOn SATA
Avatar użytkownika
pego
 
Posty: 135
Dołączył(a): 31 gru 2008, o 00:53

Re: Instalacja STAC9227 (SigmaTel) Wgranie kextu.

Postprzez rzooff » 10 lut 2009, o 13:12

Wszystko to można zrobić z poziomu terminala bez dodatkowych programów:
http://forum.osx86.pl/viewtopic.php?f=17&t=488
Ale skoro obsługa kext helpera jest dla Ciebie niejasna to odpuść sobie.
Retail 10.6.3(64bit) + Chameleon 2 | ASUS P5B-V | C2D E4600 2,4 Ghz | 4GB DDR2 800Mhz | GeForce 8400GS
Retail 10.6.3(32bit) + Chameleon 2 | Toshiba Satellie L40-17R
rzooff
 
Posty: 1114
Dołączył(a): 19 gru 2008, o 13:21
Lokalizacja: warszawa

Re: Instalacja STAC9227 (SigmaTel) Wgranie kextu.

Postprzez pego » 10 lut 2009, o 13:16

Czy powiwdzialem ze jest nei jasna? Zadalem proste pytanie tylko.
OS: iAtkos 10.5.5
MB:Intel DG965SS (965)
CPU:Intel Pentium D 2.66GHz
VGA:NVIDIA GeForce8600GT 256MB (DDR2)
RAM:GoodRam 3x1GB (667mHz)
LAN: Intel 82566DC Gigabit
Audio:SigmaTel HD Audio STAC9227
HDD:WD 250GB SATA
DVD:LiteOn SATA
Avatar użytkownika
pego
 
Posty: 135
Dołączył(a): 31 gru 2008, o 00:53

Następna strona

Powrót do Karty muzyczne

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość

cron