WiFi Realtek 8187b

Problemy i sterowniki (kexty) do kart LAN i Wireless (karty WiFi) oraz pozostały sprzęt sieciowy.

WiFi Realtek 8187b

Postprzez zewlak » 29 wrz 2009, o 22:45

Problem pojawił się już tutaj, ale nie został rozwiązany: viewtopic.php?f=28&t=1211&p=8272&hilit=8187b#p8272

W teorii są sterowniki specjalnie dla RTL 8187b, ale niestety wieszają się na Leopardzie.

Znalazłem również takie cudo na angielskich forach:
Next, let's get your wireless connection up and running. As with my first tutorial, this method seems a little screwed up, and if someone has a better way of getting it running, PLEASE post a response! But, for the time being, you'll need three files from your package here:
-87_Mac10.4_v1309.zip
-87B_Mac10.4_v1117.zip
-f5d9050v4mac.dmp
Get all three of these copied over to the desktop and just follow the instructions (no matter how stupid they may seem!):
- unpack 87_Mac10.4_v1309.zip
- in the unpacked files, run the setup script
- accept all the defaults, and reboot when prompted
- after reboot, run the uninstaller script
- unpack 87BMac10.4_v1117.zip
- in those unpacked files, run the setup script
- accept all the defaults, and reboot when prompted
- after the reboot, browse to your hard drive in the following path "\System\Library\Extensions\RTL8187B.kext\Contents\"
- open the "Info.plist" file in TextEdit, and find the value of "33161" and change it to "33175"; save and close the file
- mount the "f5d9050v4mac.dmg" image, run the setup and reboot (you're almost done now!)
- upon reboot, magically, the little crab will appear in the dock and you'll have a brand new interface
- click on the crab, and configure the settings for the Realtek wireless; add them to your profile so they'll start automatically
Like I said at the begging of this section, it's really an a**-backwards way of getting it up and running, but after trying MANY different methods, it seems to be the only one that works.

źródło: http://www.insanelymac.com/forum/index. ... pic=140696

Z tym, że pliki, których autor używa wygasły na swerwerze rapida ( http://rapidshare.com/files/172774071/Tobhiba.zip )..
Szukałem ich po nazwie w googlach, ale bez skutku... Ktoś miał podobny problem i się z nim uporał?

Z góry dzięki
zewlak
 
Posty: 7
Dołączył(a): 28 wrz 2009, o 15:55

Re: WiFi Realtek 8187b

Postprzez rzooff » 30 wrz 2009, o 08:26

Ja ściągałem po prostu ze strony realteka - mam to samo WiFi w swojej Toshibie:
http://www.realtek.com.tw/downloads/dow ... e#RTL8187B
Na początku dość opornie szła konfiguracja, ale działa.
Retail 10.6.3(64bit) + Chameleon 2 | ASUS P5B-V | C2D E4600 2,4 Ghz | 4GB DDR2 800Mhz | GeForce 8400GS
Retail 10.6.3(32bit) + Chameleon 2 | Toshiba Satellie L40-17R
rzooff
 
Posty: 1114
Dołączył(a): 19 gru 2008, o 13:21
Lokalizacja: warszawa

Re: WiFi Realtek 8187b

Postprzez zewlak » 30 wrz 2009, o 10:47

Rozumiem, że po zainstalowaniu tego sterownika trzeba uruchomić program z 'krabem' czyli Realtek UBS WLAN Client Utility i tam jest konfiguracja tego, zgadza się?

Jak ja włączam te ze strony Realteka to się wieszają - Program nie odpowiada.

To dziwne, bo karta jest wykrywana przez system pod USB Hi-Speed
Urządzenie Composite:

ID produktu: 0x8197
ID producenta: 0x0bda (Realtek Semiconductor Corp.)
Wersja: 2.00
Numer seryjny: 00e04c000001
Prędkość: do 480 Mb/sek.
Producent: Manufacturer_Realtek
ID lokacji: 0xfd600000
Natężenie dostępne (mA): 500
Natężenie wymagane (mA): 500

Zatem to pewnie nie przez sterowniki do karty tylko może jakiś inny problem sprzętowy? Pomysły?
zewlak
 
Posty: 7
Dołączył(a): 28 wrz 2009, o 15:55

Re: WiFi Realtek 8187b

Postprzez rzooff » 30 wrz 2009, o 12:50

8187B to karta na USB - tak samo ją będziesz widział i po windowsem.

U mnie też na początku tak było, a chyba po restarcie czy dwóch zaskoczyło.
Program uruchamia się sam kilka chwil po starcie. Jak będziesz go popędzał wybierając "kraba" z aplikacji, to aplikacja nie odpali.
Retail 10.6.3(64bit) + Chameleon 2 | ASUS P5B-V | C2D E4600 2,4 Ghz | 4GB DDR2 800Mhz | GeForce 8400GS
Retail 10.6.3(32bit) + Chameleon 2 | Toshiba Satellie L40-17R
rzooff
 
Posty: 1114
Dołączył(a): 19 gru 2008, o 13:21
Lokalizacja: warszawa

Re: WiFi Realtek 8187b

Postprzez zewlak » 2 paź 2009, o 13:48

Próbowałem na setki sposobów... i nic. Krab sam z siebie ani razu się nie włączył. Najgorsze jest to, że za bardzo nie wiadomo dlaczego skoro innym działa na tej karcie. Chyba pozostaje mi się pogodzić, że internet będzie tylko z kabla..?

Szcze tylko nadmienię, że po postawieniu iPC (wybrałem stery do 8187b przy instalacji) od razu przywitał mnie komunikat o złych uprawnieniach. Kliknąłem "Fix it", coś tam zrobił sobie, zrestartował się i cisza. To samo jest jak instaluje kexty ściągnięte ze strony Realteka. Może jest cały czas problem z uprawnieniami mimo wszystko i dlatego się nie uruchamia?
zewlak
 
Posty: 7
Dołączył(a): 28 wrz 2009, o 15:55

Re: WiFi Realtek 8187b

Postprzez rzooff » 2 paź 2009, o 14:55

System sam z siebie umie naprawić uprawnienia tylko plików, które zna - czyli oryginalnych. Kextów firm 3cich i hakintoshowych już nie.
Spróbuj naprawić wszystkie uprawnienia w /S/L/E i także w Extra:
Kod: Zaznacz cały
sudo -s     (podaj swoje hasło)
chown -R 0:0 /Extra
chmod -R 755 /Extra
chown -R 0:0 /System/Library/Extensions
chmod -R 755 /System/Library/Extensions
diskutil repairpermissions /     (ta funkcja trwa kilka minut)
rm /System/Library/Extensions.mkext
reboot


Przy uruchamianiu włącz tryb verbose (-v). Jeśli problem nie minie, to może będzie widać jakiś błąd związany z 8187b...
Retail 10.6.3(64bit) + Chameleon 2 | ASUS P5B-V | C2D E4600 2,4 Ghz | 4GB DDR2 800Mhz | GeForce 8400GS
Retail 10.6.3(32bit) + Chameleon 2 | Toshiba Satellie L40-17R
rzooff
 
Posty: 1114
Dołączył(a): 19 gru 2008, o 13:21
Lokalizacja: warszawa

Re: WiFi Realtek 8187b

Postprzez zewlak » 2 paź 2009, o 18:48

Bez skutku.. Naprawiłem uprawnienia, a na -v na pierwszy rzut oka nic a'propos WiFi nie widać.. :/
zewlak
 
Posty: 7
Dołączył(a): 28 wrz 2009, o 15:55


Powrót do Karty sieciowe

Kto przegląda forum

Użytkownicy przeglądający ten dział: Bing [Bot] i 1 gość

cron