Strona 1 z 3

Safari 4 Public Beta

PostNapisane: 24 lut 2009, o 16:51
przez woytas
Nowe Safari do ściągnięcia ze strony Apple

Obrazek

Zmiany:
Kod: Zaznacz cały
http://appleblog.pl/safari-4-beta


Acid3:
Obrazek

I jeszcze tips jak przywrócić stare karty jakby ktoś był zainteresowany.

Wklejcie to do terminala i restart safari:
Kod: Zaznacz cały
defaults write com.apple.Safari DebugSafari4TabBarIsOnTop -bool NO

Re: Safari 4 Public Beta

PostNapisane: 25 lut 2009, o 16:28
przez xavar
A ja nie moge zainstalować ; / Wyskakuje mi że mam za starą wersje systemu . Wymagana to 10.5.4 a ja mam Ideneba v1.3 z leo 10.5.5 .Czy ktoś wie czego to może być przyczyna i jak sobie poradzić z tym problemem?

Re: Safari 4 Public Beta

PostNapisane: 25 lut 2009, o 16:34
przez rzooff
Wymagana to 10.5.6 i wtym problem (także u mnie ;) ).
Ale i tak nadal nie ma gestów...

Re: Safari 4 Public Beta

PostNapisane: 25 lut 2009, o 17:44
przez gadowsk
Możesz oszukać i zrobić sobie 10.5.6 w bardzo prosty sposób poprzez zmianę odpowiedniego stringa w tym pliku:
Kod: Zaznacz cały
/System/Library/CoreServices/SystemVersion.plist

Tam gdzie masz 10.5.5 zmieniasz na 10.5.6 i restartujesz system.
Teraz pokaże ci, że masz system 10.5.6 ale to nie prawda. Wystarczy to by zainstalować już nowe Safari a także nowy iWork09.
Po tym powróć dla bezpieczeństwa do starych ustawień jakie miałeś czyli na 10.5.5 w wyżej wymienionym pliku.

Re: Safari 4 Public Beta

PostNapisane: 25 lut 2009, o 21:53
przez xavar
A czy po zmianie musze zrestartowac kompa ? Bo jak prubuje odrazu po zmianach w pliku to teraz zamaist ze musze miec nowa wersje wyskakuje mi że uknow_error ;/

A może poprostu zrobic update do 10.5.6 jest to możliwe ? Jeżeli tak to czy nie strace kextów od np dzwieku lub czy nie przestana nagle dzialac; /

Re: Safari 4 Public Beta

PostNapisane: 25 lut 2009, o 22:17
przez gadowsk
Ja jak jeszcze miałem 10.5.5 to zmieniłem zapis w pliczku z poziomu Windowsa i wystartowałem system bez najmniejszych problemów.
Miałem w opisie kompa że mam 10.5.6 i nawet SU wykrywał aktualizacje właśnie do wersji 10.5.6 więc to powoduje takie oszukanie systemu.

Potem powróciłem do poprzedniej wersji poprzez zmianę w tym oto pliczku i maiłem z powrotem 10.5.5 a zainstalowany program działał bezproblemowo.
Wtedy instalowałem nowego iWork09. Myślę że to samo może być w przypadku instalacji jakiegokolwiek programu wymagającego wersji systemu właśnie 10.5.6

Teraz to już mam iDeneb v1.4 10.5.6 więc nie mam już problemów z instalacją czegokolwiek no chyba że wydadzą kolejny update systemu do kolejnego numerka i na podstawie tego będą udostępniać instalację programów to już nie będę mógł instalować ich bez zmiany w ustawieniach systemu.

Re: Safari 4 Public Beta

PostNapisane: 26 lut 2009, o 16:33
przez xavar
Niestety podany przez ciebie sposob nie działa : / cały czas nie pozwala zainstalować .

Re: Safari 4 Public Beta

PostNapisane: 26 lut 2009, o 17:27
przez woytas
xavar napisał(a):Niestety podany przez ciebie sposob nie działa : / cały czas nie pozwala zainstalować .


A restartowałeś komputer? Ewentualnie jeszcze spróbuj naprawić uprawnienia, może coś pomoże i sprawdź jabłko na belce Ten Macintosh... czy zmienił na wersję 10.5.6
Zostaje oczywiście jeszcze jedna sprawa, czyli aktualizacja Security Update przeznaczona dla 10.5.6 bez tego co czytałem nie ruszy.

Re: Safari 4 Public Beta

PostNapisane: 27 lut 2009, o 22:24
przez xavar
wersja była 10.5.6 . I tak restartowałem , teraz wgrałem IPC najnowszego , i ten sam problem . Może trzeba zrobić ten secruity update , a bez problemu da się to zrobić przez software update ?

Re: Safari 4 Public Beta

PostNapisane: 27 lut 2009, o 22:54
przez gadowsk
Przez SU możesz w zasadzie bezpiecznie robić większość aktualizacji oprócz tych co podnoszą numerek w wersji systemu.