iLife 09 i iWork 09 plikDMG i błąd weryfikacji i instalacji.

Problemy związane z aktualizacją, instalacją czy użytkowaniem programów na OSx86

iLife 09 i iWork 09 plikDMG i błąd weryfikacji i instalacji.

Postprzez quoka84 » 3 cze 2009, o 15:36

Od samego początku czy na iPC, iDeneb czy teraz na Retail'u mam problem z niektórymi dmg'ami. Pojawia mi się błąd "przepełnienie kodeka" albo częściej "zła suma kontrolna". Wgrałem seatbelt i to samo. Problem pojawia się w iLife i iWork (trial ze strony apple) i nie wiem co jest. Szukam i naknąłem się tylko na seatbelt. Wcześniej wywalały mi Combo Update'y albo po seatbelt problem zniknął. Co z tym iLife i iWork? Photoshop CS4 Trial (ze strony Adobe) to samo: suma kontrolna.

Pytam bo nie wiem czego mam szukać, a może ktoś wie.

Z góry dzięki
MacOS X 10.5.7 (Retail) + Chameleon-2.0-r431
Asus P5B-V (G965) + Intel C2D E4500 | WD 250GB AHCI SATA-II (Guid) | Radeon X1950 PRO 256MB (PCI-E) | 2GB DDR2 800MHz
Avatar użytkownika
quoka84
 
Posty: 7
Dołączył(a): 3 cze 2009, o 15:02

Re: iLife 09 i iWork 09 plikDMG i błąd weryfikacji i instalacji.

Postprzez rzooff » 3 cze 2009, o 15:50

Mam prawie indentyczny konfig i u mnie nic podobnego nie ma miejsca.
Problem z seatbelt.kext, a dokładniej to z jego konkretną wersją, dotyczy kernela voodo. A tego chyba nie masz?
Napisz więcej. Jak instalowałeś retaila, co masz w Extra, co dodatkowow w S/L/E... Może tam masz coś namieszane?
Czasem bywa tak, że przeszkadza coś zupełnie innego. Np. u mnie skge.kext (pewnie też masz) wywołuje raz na jakiś czas KP przy boot.
Retail 10.6.3(64bit) + Chameleon 2 | ASUS P5B-V | C2D E4600 2,4 Ghz | 4GB DDR2 800Mhz | GeForce 8400GS
Retail 10.6.3(32bit) + Chameleon 2 | Toshiba Satellie L40-17R
rzooff
 
Posty: 1114
Dołączył(a): 19 gru 2008, o 13:21
Lokalizacja: warszawa

Re: iLife 09 i iWork 09 plikDMG i błąd weryfikacji i instalacji.

Postprzez quoka84 » 3 cze 2009, o 16:37

W extra nie mam nic ponieważ nie ma takiej potrzeby a chameleona mam na partycji efi. Zainstalowałem Retaila bodaj 10.5.1, potem Combo Update 10.5.6, następnie Update 10.5.7, chameleon na EFI bez katalogu Extra. Do s/l/e wrzuciłem skge, disabler, jmicron, kexty do ich8, azaliaaudio, tego seatbelta, i stery do wifi usb.

Dodam, że historia z dmg'ami od samego początku i w retailu z folderem Extra i w iPC i w iDeneb. To coś głębszego. Ale co? iLife'a już 3 raz ściągam. iWork na początku się instalował a teraz mi nie chce weryfikacji przejść. Ściągnięty nowy to samo. Photoshop to samo. Pomijam weryfikację to się czasem instaluje a czasem od razu wywala. iLife to samo. Czasem na iPhoto wywali a czasem zainstaluje połowę i przy końcu błąd typu "uszkodzony plik źródłowy. Na wcześniejszych instalacjach Combo nie mogłem przez to zaistalować, a po ściągnięciu Combo 3 raz z apple już weryfikacja przeszła.
Może jest jakaś alternatywa dla DiskMounter'a? Jakaś z koniem w logo nie pomaga (sprawdzałem).

Konfig mam podobny bo ściągnąłem przy zakupie ;)
Wcześniej miałem Macintosha PowerBook G4 i chciałem pobawić się w Hackintosha.
MacOS X 10.5.7 (Retail) + Chameleon-2.0-r431
Asus P5B-V (G965) + Intel C2D E4500 | WD 250GB AHCI SATA-II (Guid) | Radeon X1950 PRO 256MB (PCI-E) | 2GB DDR2 800MHz
Avatar użytkownika
quoka84
 
Posty: 7
Dołączył(a): 3 cze 2009, o 15:02

Re: iLife 09 i iWork 09 plikDMG i błąd weryfikacji i instalacji.

Postprzez quoka84 » 3 cze 2009, o 16:42

A czy jest możliwość zmiany w chameleonie voluminu na stały? Mam dwie partycje i oczywiście chce mi bootować z tej bez systemu i musze za każdym razem czekać i wciskać klawisz by zmienić na właściwy volumin. Wkurza mnie to. Na insanelymac piszą że się nie da. Przynajmniej nie znalazłem innej wypowiedzi.

Dzięki


PS. karta skge może ściągać mi pliki niekompletnie?
MacOS X 10.5.7 (Retail) + Chameleon-2.0-r431
Asus P5B-V (G965) + Intel C2D E4500 | WD 250GB AHCI SATA-II (Guid) | Radeon X1950 PRO 256MB (PCI-E) | 2GB DDR2 800MHz
Avatar użytkownika
quoka84
 
Posty: 7
Dołączył(a): 3 cze 2009, o 15:02

Re: iLife 09 i iWork 09 plikDMG i błąd weryfikacji i instalacji.

Postprzez rzooff » 3 cze 2009, o 20:38

Tu masz forum chameleona, gdzie m.in. znajdziesz dokumentację. Jest tam opisana opcja wyboru "default partition" - powinno być wygodniej.
Sam problem pokazywania partycji bez systemu - przynajmniej tych makowych - wg zapewnień sckevyn'a będzie działać w wersji finalnej. I wtedy Twój problem sam zniknie.

skge.kext to dłuższa historia. Na płytach P5B powoduje on raz na kilka uruchomień systemu panikę. Restart i już jest OK, ale strasznie mnie to wkurza.
Natomiast nie miałem problemów ze ściąganymi plikami. Z tym, że nie ściągałem chyba nic większego niż Combo Update 10.5.6 i 10.5.7.

quoka84 napisał(a):W extra nie mam nic ponieważ nie ma takiej potrzeby

Extra nie jest wynikiem potrzeby. To jest miejsce gdzie możesz umieścić dużą część nieoryginalnych kextów. Wtedy masz system wolny lub prawie wolny od modyfikacji. Dzięki czemu jest szansa, że przy wszelkiego rodzaju update'ach, nawet przez SU, nie powinno się nic złego stać.
W przypadku Chameleona katalog Extra nie znajduje się na partycji EFI (choć tak też można), tylko na dysku z systemem. Skoro masz Chameleona2 to zapewne masz tam ten folder, a w nim Themes i Extensions z kextami, które instalator sam dorzuca. Nawet gdybyś instalował ręcznie to i tak musisz gdzieś mieć Themes?

quoka84 napisał(a):Zainstalowałem Retaila bodaj 10.5.1

No tylko ja pytałem jaką metodą?

quoka84 napisał(a):Do s/l/e wrzuciłem skge, disabler, jmicron, kexty do ich8, azaliaaudio, tego seatbelta, i stery do wifi usb.

Może to ten seatbelt tak miesza? Powinno Ci chodzić jak trzeba z seatbelt.kext, który jest normalnie z systemem w danej wersji.
Poza tym na tej liście powinieneś mieć jeszcze AppleDecrypt.kext, LegacyAppleAHCIPort.kext, LegacyIOAHCIBlockStorage.kext. Być może masz je - lub ich odpowiedniki - w Extra, tylko o tym nie wiesz? ;)

quoka84 napisał(a):Dodam, że historia z dmg'ami od samego początku i w retailu z folderem Extra i w iPC i w iDeneb. To coś głębszego.

Dziwne dziwne. Miałem obie dystrybucje i też nie było problemów.
Może wybierałeś przy instalacji jakiś dodatkowy fix, lub, co najbardziej prawdopodobne, wspomniany seatbelt i stąd cały problem?
Tu masz mój z wersji 10.5.7:
http://dl.getdropbox.com/u/750399/OSx86/seatbelt.kext.zip
Myślę, że to + porządek w kextach (Extra i S/L/E)

To co działa z Extra mam w Extra:
Obrazek
Reszta - dokładnie 3 sztuki: nvkush, kx drivers, skge - są w S/L/E.
Nie mam żadnych innych dodatków ani modyfikacji.

quoka84 napisał(a):Konfig mam podobny bo ściągnąłem przy zakupie ;)

Z mojego? Jak kupowałem to nie wiedziałem jeszcze o możliwościach instalacji MacOS na PC. Teraz wybrałbym trochę inny zestaw ;)
Retail 10.6.3(64bit) + Chameleon 2 | ASUS P5B-V | C2D E4600 2,4 Ghz | 4GB DDR2 800Mhz | GeForce 8400GS
Retail 10.6.3(32bit) + Chameleon 2 | Toshiba Satellie L40-17R
rzooff
 
Posty: 1114
Dołączył(a): 19 gru 2008, o 13:21
Lokalizacja: warszawa

Re: iLife 09 i iWork 09 plikDMG i błąd weryfikacji i instalacji.

Postprzez quoka84 » 4 cze 2009, o 00:13

System stawiałem z istniejącego systemu iPC (na dysku usb) wg tej http://forum.osx86.org.pl/topics4/instalacja-mac-os-x-leopard-1056-z-plyty-retail-vt14.htm instrukcji. Z lekką modyfikacją, ponieważ po instalacji OSa i Comba wgrywałem Chameleona w "Dostosuj" zaznaczając "Chameleon EFI HFS" zamiast "Standard" bootloader wskakuje mi na EFI partycję a na systemowej nie tworzy mi się folder "Extra". Wszystko fajnie mi bootuje tylko mnie wkurza, że zamiast mi domyślnie z voluminu systemowego chce bootować z jakiego mu popadnie, więc czekam zawsze by klawisz wcisnąć i zmienić volumin bootowania. Kexty wrzucam do S/L/E i update'y mi krzywdy nie robią. Kexty wrzuciłem identyczne oprócz od grafy. Seatbealta nie zmieniałem przy instalacji. Więc to nie on.
Już pisałem, że seatbelta wgrałem dzisiaj bodajże, ponieważ natknąłem się na takie rozwiązanie na insanley.
Twoją płytę tylko zgapiłem bo tania była i nie wiedziałem jaką kupić a tu widziałem na forum i w wiki, że śmiga.

Czy to możliwe, że RAM mi knoci instalowanie? Kupiłem jakiś badziew GoodRam, może to one? Co oznacza to przepełnienie kodeka?
MacOS X 10.5.7 (Retail) + Chameleon-2.0-r431
Asus P5B-V (G965) + Intel C2D E4500 | WD 250GB AHCI SATA-II (Guid) | Radeon X1950 PRO 256MB (PCI-E) | 2GB DDR2 800MHz
Avatar użytkownika
quoka84
 
Posty: 7
Dołączył(a): 3 cze 2009, o 15:02

Re: iLife 09 i iWork 09 plikDMG i błąd weryfikacji i instalacji.

Postprzez quoka84 » 4 cze 2009, o 00:29

Mógłbyś mi podrzucić swoje "LegacyAppleAHCIPort.kext"? Ponieważ ja mam u siebie "AppleAHCIPort.kext", a może to duża różnica.

Dzięki
MacOS X 10.5.7 (Retail) + Chameleon-2.0-r431
Asus P5B-V (G965) + Intel C2D E4500 | WD 250GB AHCI SATA-II (Guid) | Radeon X1950 PRO 256MB (PCI-E) | 2GB DDR2 800MHz
Avatar użytkownika
quoka84
 
Posty: 7
Dołączył(a): 3 cze 2009, o 15:02

Re: iLife 09 i iWork 09 plikDMG i błąd weryfikacji i instalacji.

Postprzez rzooff » 4 cze 2009, o 09:29

Rożnica raczej niewielka w przypadku takiej konfiguracji. Ważne by nie mieć dwóch kextów obsługujących to samo.
Ten mój pochodzi właśnie z tutoriala, z którego korzystałeś.
A Extra pewnie masz, tylko w takim razie na tej ukrytej partycji z Chameleonem.

Skoro jednak to samo działo się na iPC i iDeneb, bez dodatków w postaci seatbelt.kext, to chyba jednak nie tu leży problem.
Zrób jeszcze rachunek sumienia czy czegoś nie dodałeś - jakiś shutdown fix, usb fix...? Jeśli nie to może faktycznie jakiś element sprzętowy nie działa jak trzeba. Ja mam dość porządny ram OCZ. Nie potrafię jednak powiedzieć czy to może być to - z takimi komunikatami się nie spotkałem ani u siebie ani nie czytałem o tym nigdzie.

Ale jeszcze jest jedna możliwość - bios.
Po pierwsze, jeśli tego nie zrobiłeś, to zainstaluj sobie najnowszy, że strony Asusa (niestety chyba nie ma innej opcji jak zrobić to w Windowsie).
U mnie mam włączone AHCI (także dla JMicrona), Legacy USB - Enabled i włączone Memory Remap Feature (czy coś w tym guście). Choć to ostatnie przy 2GB nie ma chyba sensu.
Retail 10.6.3(64bit) + Chameleon 2 | ASUS P5B-V | C2D E4600 2,4 Ghz | 4GB DDR2 800Mhz | GeForce 8400GS
Retail 10.6.3(32bit) + Chameleon 2 | Toshiba Satellie L40-17R
rzooff
 
Posty: 1114
Dołączył(a): 19 gru 2008, o 13:21
Lokalizacja: warszawa

Re: iLife 09 i iWork 09 plikDMG i błąd weryfikacji i instalacji.

Postprzez quoka84 » 4 cze 2009, o 12:29

Żadnych fix'ów nie wgrywałem dodatkowych, bios sprawdzę, ale mam chyba najnowszy. Chyba to wina sprzętu (dysku albo pamięci) skoro na wszystkich dystrybucjach mi tak knoci. gdybym wiedział co odpowiada za sprawdzanie dmg przy montowaniu, albo co bierze udział w instalacji (jakie kexty) programów z dmg.

Ściągam iLife'a poraz 3 z innego źródła. ;\

Thanks anyway...
MacOS X 10.5.7 (Retail) + Chameleon-2.0-r431
Asus P5B-V (G965) + Intel C2D E4500 | WD 250GB AHCI SATA-II (Guid) | Radeon X1950 PRO 256MB (PCI-E) | 2GB DDR2 800MHz
Avatar użytkownika
quoka84
 
Posty: 7
Dołączył(a): 3 cze 2009, o 15:02

Re: iLife 09 i iWork 09 plikDMG i błąd weryfikacji i instalacji.

Postprzez quoka84 » 5 cze 2009, o 11:58

Oto jaka metodą instaluję teraz programy typu Life, iWork.

Pokazuję ukryte pliki w dmg, wchodzę w folder gdzie jest plik Archive.pax.gz, kopiuję na biurko, zmieniam uprawnienia na "nazwa użytkownika" "staff" (wcześniej tylko root), wypakowuję plik i z niego wychodzi Archive.pax. Potem w terminalu cd do folderu gdzie mam Archive.pax (lepiej nie na biurku bo nam wypakuje tam pliki a przy dużej ilości może zaśmiecić). Dalej wpisujemy

gzip -cd Archive.pax | pax -r

Pokaże jakieś komendy i po jakimś czasie skończy i mamy pliki, które należy poumieszczać wg utworzonych folderów.

I działa. Na piechote ale mam iLife'a i iWork'a

Może, ktoś ma ten sam problem (nie życzę) to proszę.
MacOS X 10.5.7 (Retail) + Chameleon-2.0-r431
Asus P5B-V (G965) + Intel C2D E4500 | WD 250GB AHCI SATA-II (Guid) | Radeon X1950 PRO 256MB (PCI-E) | 2GB DDR2 800MHz
Avatar użytkownika
quoka84
 
Posty: 7
Dołączył(a): 3 cze 2009, o 15:02


Powrót do OSx86 Programy

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 2 gości